Thursday, July 27, 2006

AIX Basic & Important Commands (AIX 5L)




HOW TO's ABOUT KERNEL

Kernel is 32-bit or 64-bit?

bootinfo -K

Switch from 5.2 & 5.3?

bootlist -m normal hdisk1

Uniprocessor kernel or a multiprocessor kernel?

/unix -> /usr/lib/boot/unix_up   # 32 bit uniprocessor kernel
/unix -> /usr/lib/boot/unix_mp # 32 bit multiprocessor kernel
/unix -> /usr/lib/boot/unix_64 # 64 bit multiprocessor kernel

Note:
AIX 5L Version 5.3 does not support a uniprocessor kernel.

Move from 32-bit kernel to 64-bit kernel?

ln -sf /usr/lib/boot/unix_64    /unix
ln -sf /usr/lib/boot/unix_64 /usr/lib/boot/unix

bosboot -ad /dev/hdiskxx
shutdown -r

Move from 64-bit kernel to 32-bit kernel?

ln -sf /usr/lib/boot/unix_mp    /unix
ln -sf /usr/lib/boot/unix_mp /usr/lib/boot/unix

bosboot -ad /dev/hdiskxx
shutdown -r

The /dev/hdiskxx directory is where the boot logical volume /dev/hd5 is located. To find out what xx is in hdiskxx, run the following command:

 lslv -m hd5


HOW TO's ABOUT HARDWARE

If pSeries machine (hardware) is 32-bit or 64-bit?

bootinfo -y

Real memory (KB) does the machine have?

bootinfo -r    

lsattr -El sys0 -a realmem 

Values of attributes for devices in the system?

lsattr -E -l sys0

Number of processors?

lscfg  grep proc

Number of Hard Disks?

lspv

Detailed configuration of the system?

lscfg

The following options provide specific information:

-pDisplays platform-specific device information. The flag is applicable to AIX 4.2.1 or later.
-vDisplays the VPD (Vital Product Database) found in the customized VPD object class.

Find chip type, system name, node name, model number, and so forth?

The uname command provides details about the system.

uname -p Displays the chip type of the system. For example, PowerPC.
uname -r Displays the release number of the operating system.
uname -s Displays the system name. For example, AIX.
uname -n Displays the name of the node.
uname -a Displays the system name, nodename, version, machine ID.
uname -M Displays the system model name. For example, IBM, 9114-275.
uname -v Displays the operating system version.
uname -m Displays the machine ID number of the hardware running the system.
uname -u Displays the system ID number.

HOW TO's ABOUT AIX OS

Version, release, and maintenance level of AIX OS?

oslevel -r

lslpp -h bos.rte

Change the size of a filesystem?

To increase the /usr filesystem size by 1000000 512-byte blocks, type:

chfs -a size=+1000000 /usr

Note:
In AIX 5.3, the size of a JFS2 file system can be shrunk as well.

Mount a CD?

mount -V cdrfs -o ro /dev/cd0  /cdrom

IP address of the machine?

Type one of the following:

ifconfig -a

Which fileset contains a particular binary?

To show bos.acct contains /usr/bin/vmstat, type:

lslpp -w /usr/bin/vmstat

Or to show bos.perf.tools contains /usr/bin/svmon, type:

which_fileset svmon

Determine if all filesets of maintenance levels are installed on the system?

Type the following:

instfix -i  grep ML

Determine if a fix is installed on the system?

To determine if IY24043 is installed, type:

instfix -ik IY24043

If filesets have required prerequisites and are completely installed?

To show which filesets need to be installed or corrected, type:

lppchk -v

Get a dump of the header of the loader section and the symbol entries in symbolic representation?

Type the following:

dump -Htv

Determine the amount of paging space allocated and in use?

lsps -a

How can I see "console" messages?

Use the swcons command to redirect the console to a file. Or use
chcons to do it permanently.

Debug Messages

By default, printf in kernel do nothing. To activate output on the
tty console, you have to active the kernel by a command like :

bosboot -a -d /dev/hdisk0 -D

Check man page to use the correct /dev if you have a special installation.

After that, you have to reboot (shutdown -Fr) to use the new kernel.

No comments: